posts recentes|

Segurança > Acesso ao Itaú Internet Banking via Linux

O App Itaú para desktop é tão complicado que até o suporte tem dificuldade para prestar algum tipo de auxílio aos clientes. Começa que o app dá suporte apenas ao Windows. Para Linux, o suporte é via extenção exclusiva à Debian e Debian-like como o Ubuntu e o Mint.

Com os updates de segurança do Windows, o app para de funcionar e, em alguns casos, só volta a funcionar reinstalando. Isso me ocorreu no Windows 7 há um bom tempo atrás. No Windows 10, porém, o problema foi mais sério; o app nunca mais voltou a funcionar, e nesta oportunidade, também não voltou no Windows 7. Ambas versões do Windows exibiam o seguinte erro:

O meu caso

Essas máquinas Windows que possuo são VMs rodando no Virtual Box.

Desta última vez, acredito que o problema tenha ocorrido devido ao NAT de rede que o Virtualbox faz para manter tanto o host quanto a VM funcionando, pois tanto acesso via Browser quanto via app deixaram de funcionar, e isso em ambas versões do Windows e em computadores diferentes, mas isso é uma suspeita. Acredito nessa possibilidade, pois nos hosts onde o Virtualbox roda, o acesso encontrava-se normal. Sem a possibilidade de realizar operações pelo Linux, mas com acesso normal.

Bom, desabafo feito, vamos à solução.

Solução para acesso ao Itau Internt Banking via Linux

Para mim a solução foi focar em fazer o Internet Banking funcionar no Linux.

O Itaú dá suporte ao Linux Desktop Ubuntu e talvez Debian, já que fornece o software “Guardião” em formato .deb.

Tentei converter esse .deb para .rpm com Alien, já que uso Centos 7 no desktop. Não rolou muito bem, pois ocorreram muitos conflitos o filesystem.

A solução foi encontrada no Google, mais especificamente no site GAS antifraud.

Esse site pertence à Diebold, empresa dona da GAS Tecnologia que é responsável pelo Warsaw utilizado pelo Itaú para desktop Linux

Basta acessar o site https://diagnostico.gasantifraud.com e selecionar o banco Itau. A seguir, selecione a distro que você faz uso. Caso use Redhat, Centos, Oracle Linux, etc, use a opção “Fedora”. Um pacote será baixado em sua máquina. O instale de acordo com sua distribuição, sendo:

Debian e Debian-like

dpkg -i pacote.deb

Redhat e Redhat-like

yum localinstall pacote.rpm

Fedora

dnf localinstall pacote.rpm

Feito isso, volte ao site https://diagnostico.gasantifraud.com e, novamente, selecione o banco Itau. O site concluirá as configurações necessárias.

Agora basta reiniciar o browser e testar o acesso ao Internet Banking do Itaú.

Conclusões

Segurança é fundamental para todos nós. Facilitar a vida dos clientes também deveria, e os bancos não tem ajudado muito nesse sentido. Do Itaú, em específico, não tenho muito o que reclamar, pois ao menos o atendimento é muito prestativo. O problema mesmo é o software para Windows que, mesmo depois de desistalado, deixa várias vestígios no registro do sistema, o que acaba atrapalhando as novas instalações que acabam herdando configurações antigas. Enfim.

Vale observar ainda que não somente o Itaú utiliza o Warsaw, mas outros bancos também. Portanto, esta solução pode se aplicar à outras pessoas não relacionadas ao banco Itaú.

Boa sorte ao amigo leitor e, principalmente, ao Itaú que precisa melhorar esse app para computadores.

Abraços.

97670cookie-checkSegurança > Acesso ao Itaú Internet Banking via Linux

2 comentários

  1. Rodrigo

    Uma informação adicional, que aconteceu comigo ao tentar executar a instalação do plugin no Debian 10 (Buster) e no Google Chrome é que após baixar o arquivo “warsaw_setup_64.deb” e tentar rodar o mesmo com o comando “sudo dpkg -i warsaw_setup_64.deb”, o mesmo apresentava os seguintes erros:

    “A seleccionar pacote anteriormente não seleccionado warsaw.
    (Lendo banco de dados … 189404 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar warsaw_setup_64.deb …
    A descompactar warsaw (1.15.5-3) …
    dpkg: problemas com dependências impedem a configuração de warsaw:
    warsaw depende de zenity; porém:
    Pacote zenity não está instalado.

    dpkg: erro ao processar o pacote warsaw (–install):
    problemas de dependência – deixando desconfigurado
    A processar ‘triggers’ para man-db (2.8.5-2) …
    A processar ‘triggers’ para systemd (241-7~deb10u6) …
    Erros foram encontrados durante o processamento de:
    warsaw”

    Ao tentar instalar o zenity com o comando “apt install zenity”, obtive o seguinte erro:

    sudo apt install zenity
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    Você pode querer executar ‘apt –fix-broken install’ para corrigí-los.
    Os pacotes a seguir têm dependências desencontradas:
    zenity : Depende: libwebkit2gtk-4.0-37 (>= 2.15.1) mas não será instalado
    Depende: zenity-common (>= 3.30.0-2) mas não será instalado
    E: Dependências desencontradas. Tente ‘apt –fix-broken install’ sem nenhum pacote (ou especifique uma solução).”

    Então a solução encontrada foi rodar o “sudo apt –fix-broken install” e corrigir as dependências e só depois rodar de novo o “sudo dpkg -i warsaw_setup_64.deb” e então o plugin do warsaw foi instalado e funciona corretamente.

    Espero ter ajudado alguém com a mesma dificuldade.

  2. @wili4m Autor do post

    Perfeito, Rodrigão! Excelente comentário e tudo muito bem explicado. Obrigado por contribuir. Abração!

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.